Author Topic: Updated info for cm6206?  (Read 4111 times)

0 Members and 1 Guest are viewing this topic.

Offline daderaide

  • Newbie
  • *
  • Posts: 8
  • Milliwatts: 0
    • View Profile
Updated info for cm6206?
« on: April 05, 2016, 09:36:08 pm »
Hi Everyone!
First of all thanks for being such a great community. This forum has been a wealth of information to me in the past several weeks as I build my first laser project. Unfortunately, I have finally run into a wall that I can't seem to get past. There is a ton of great info here and on other forums on the c-media cm6206 and it's associated driver difficulties, but all of that info is several years old at this point. Some of the linked files are dead links, etc. I'm wondering if anyone has any updated details on how to get this sound card working with the laserboy correction amp? I finished building my correction amp and have successfully adjusted it to have zero output with the sound card plugged in (I've followed the adjustment walk through that has been posted here several times by James). I have the standard windows drivers installed and it is all set for 8 channel audio, but i'm not getting any signal on any of the channels except for 1 and 2, which in my case I have as the music track. I'm using the latest version of spaghetti and the music plays fine but there is no other output. when I try changing channels around in spaghetti nothing happens, so i'm assuming that for some reason it's not actually functioning on 8 channels. I have looked into tweaking the cm106.ini file, but those instructions are also several years old and for XP. I'm running windows 7 64bit. and can't find where I should put that file or if it already exists in windows 7. Any help would be greatly appreciated!!

Offline daderaide

  • Newbie
  • *
  • Posts: 8
  • Milliwatts: 0
    • View Profile
Re: Updated info for cm6206?
« Reply #1 on: April 06, 2016, 01:56:05 am »
I've been fiddling around with the driver and I now at least have action! I think the driver section of the project is working properly (I think). BUT, I'm now having other issues that may or may not be appropriate for this section of the forum but here it goes.

When trying to draw the big white circle, I have a little tiny version of it in the bottom right corner of the scan area and then this huge "blotch" of lines coming diagonally from the upper left. Is this a characteristic of correction amp being adjusted wrong? I have tried turning the pots but it doesn't affect the big diagonal, only changes the expected stuff like size and vertical/horizontal position, etc. It's almost like some kind of glitch with the glavo...?

Offline daderaide

  • Newbie
  • *
  • Posts: 8
  • Milliwatts: 0
    • View Profile
Re: Updated info for cm6206?
« Reply #2 on: April 06, 2016, 02:19:12 am »
here's what it's looking like. should I start a new topic since this isn't really related to the cm6206 anymore?


Offline daderaide

  • Newbie
  • *
  • Posts: 8
  • Milliwatts: 0
    • View Profile
Re: Updated info for cm6206?
« Reply #3 on: April 06, 2016, 01:06:56 pm »
I posted this question over on photonlexicon also and it was suggested that windows may be mixing color info into the x and y. I tried playing the circle in different colors and it does shift it all around. So, maybe this is a driver issue after all. Anyone have a suggestion on how to get windows to stop mixing the tracks together?

Offline James

  • Administrator
  • Hero Member
  • *****
  • Posts: 2089
  • Milliwatts: 46
  • Gender: Male
    • View Profile
    • LaserBoy !!!
Re: Updated info for cm6206?
« Reply #4 on: April 06, 2016, 02:40:04 pm »
Mixing the channels all together down to stereo is exactly what is happening.

Have a look into your Windows sound system settings, with the USB SND8 plugged in. There are settings associated to your speaker arrangement. You need to tell Windows you have 7.1 (8 individual speakers).

Once you do that, you will also need to make sure the driver for the device is set to 8 channels and readjust your correction amp.

BTW Your audio signals should be on 7 & 8.

1 = X
2 = Y
3 = red
4 = green
5 = blue
6 = whatever
7 = left audio
8 = right audio

"whatever" can be a monochrome mix of RGB or Z, a time code track or nothing.

James.
« Last Edit: April 06, 2016, 02:50:31 pm by James »
LaserBoy is Sofa King Cool!
But it will never be Alpha King Done!

Offline daderaide

  • Newbie
  • *
  • Posts: 8
  • Milliwatts: 0
    • View Profile
Re: Updated info for cm6206?
« Reply #5 on: April 12, 2016, 03:06:34 pm »
ok, here's my update of what I have found as far as Windows 7 info for the c-media chips. It seems that all devices with the cm6206 are compatible with the same drivers. It doesn't matter if it's a 5.1 card, 7.1 card or even if it's not even a sound card at all!! They put this chip in a LOT of different products and they all seem to be compatible with eachothers drivers.

None of the windows drivers properly separate the audio tracks. I have tried them all. At least all that I can find. The drivers that come with these USB sound cards also don't work. I have tried 2 different OEM disks and downloaded a few others that also don't work. If the driver installs 2 different devices in your windows audio control panel, it's the wrong one.

This is the only driver I have found to work:

http://www.rosewill.com/media/Download_Files/Drivers/driver%20for%20rhts-8206%20windows%20xp%20vista%207%20v1.0.zip

This is a zip file, so you have to download an unzipping program. Winzip or winRAR will both work. It might say it's the evaluation version, but I've had it for months now and it still works.

It's for a set of gaming headphones, but don't let that bother you. It comes with an applet for the audio driver that gives you access to more controls that just the standard windows control panel. When you install it, it should replace any other c-media, or windows universal USB sound device drivers (it did for me anyway). I just went into the folder where I unzipped the driver and navigated to /fscommand/W7 and double click on "setup". This automatically replaced the other driver.

 If it doesn't work for you, go into your control panel and select the audio device that was first installed (I have done it for both devices when it has installed 2 and it doesn't seem to matter which one you choose).

Go to the properties window and again click properties.
Then click "change settings" and go to the "driver" tab and click "update driver".
Click "browse my computer for software" and click browse.
Navigate to the folder where you unzipped the driver that you downloaded and make sure that the "include subfolders" box is checked. and then click next. It should find the driver and update it.

Once you have the driver installed you have to go back into the control panel and select the new device that it added. It should be called "Speakers - USB Multi-Channel Audio Device".

Click configure and select either 5.1 or 7.1 depending on the actual sound card that you have.
Click next and make sure all of the boxes in that screen are checked.
Click next and again check all of the boxes for full range speakers.
Click finish

Now with the same device selected in the control panel view, click properties.
Go to the advanced tab and make sure that the default format is set to 16 bit, 48000 Hz (DVD Quality). Mine was set to 44000 Hz by default and this will make the laser images distorted.
Do not set this device as default!!! Leave your internal sound card as default. I also turned off system sounds to be on the safe side.

I have also seen a lot of people say that you need to go into your internal sound card device and go to the "Enhancements" tab and click the box for "disable all enhancements". I'm not actually sure if this is necessary since it should only affect system sounds but I did it anyway.

If the driver installed properly, you should also have a new item in your control panel main view in addition to "Sound".
You should see "USB Multi-Channel Audio Device" double click it.
This is where you will see at the top left under "System Input" a drop down box where you can select the number of channels. Select 8 even if you only have a 6 channel card.
Next, look down at "Output Mode" and the drop down should list the max number of speakers that are specific to your particular sound card.
I left all other settings as default.

OK! That's it. With this setup I am able to get Laserboy to output correctly to all channels without mixing things together.

Offline James

  • Administrator
  • Hero Member
  • *****
  • Posts: 2089
  • Milliwatts: 46
  • Gender: Male
    • View Profile
    • LaserBoy !!!
Re: Updated info for cm6206?
« Reply #6 on: April 12, 2016, 04:32:27 pm »
I just got a copy of this a put it here:

http://laserboy.org/driver_for_rhts-...sta_7_v1.0.zip

James.
LaserBoy is Sofa King Cool!
But it will never be Alpha King Done!

 

SMF spam blocked by CleanTalk